Post Reply 
[X60] 1.5.1 - 20111122 [please check]
2012-01-17, 14:49 GMT
Post: #1
1.5.1 - 20111122 [please check]
Works on: Onyx Boox X60, Bebook Club
Version: 1.5.1
Datecode: 20111122 (not sure, please check in About screen)
Original location: http://mybebook.com/support/


.zip  onyx_x60_1.5.1_20111122.zip (Size: 98.53 MB / Downloads: 48)
Visit this user's website Find all posts by this user
Quote this message in a reply
2012-01-21, 19:15 GMT
Post: #2
RE: [X60] 1.5.1 - 20111122 [please check]
please, be careful! this firmware is buggy and has no browser.

on my device after this firmware battery bar show 0% charge always.

but firmware has new feature
there is a new fb2\epub reader Cool Reader. It is better than default fbreader
Find all posts by this user
Quote this message in a reply
2012-01-22, 12:27 GMT
Post: #3
RE: [X60] 1.5.1 - 20111122 [please check]
Do you have both a X60S and a X60 ?
You checked the datecode for the X60S firmware, but this is an X60 firmware.

I am not sure the firmwares between X60 and X60S are compatible.
Visit this user's website Find all posts by this user
Quote this message in a reply
2012-01-22, 15:11 GMT
Post: #4
RE: [X60] 1.5.1 - 20111122 [please check]
i have boox 60 and usually its normal to use x60 and x60s firmwares. as far as i understand firmwares for s and not s are mostly the same, just s-wares hides functions that use stylus, wifi and so on.
i have the same bug with battery bar in russian firmware for [A]60 1.5.1 20110927 (just in case here is the link for this http://www.onyx-boox.ru/files/OnyxBOOX60_20110927.zip)
Find all posts by this user
Quote this message in a reply
2012-01-22, 15:36 GMT
Post: #5
RE: [X60] 1.5.1 - 20111122 [please check]
You are right ofcourse: You are able to use a S firmware on a non-S device (but with limited functionality) but there have been problems when people did it the other way around.

Interesting, where did you find that download link ?
It is not on the support page ( http://www.onyx-boox.ru/support )

I will add that firmware to the Downloads section here as well.
Visit this user's website Find all posts by this user
Quote this message in a reply
2012-01-22, 15:40 GMT
Post: #6
RE: [X60] 1.5.1 - 20111122 [please check]
it was on their site for a short period of time. Then they hide it without any explanation. Btw, some people on russian forum say, that they use it without any problems.
Find all posts by this user
Quote this message in a reply
2012-01-22, 15:45 GMT
Post: #7
RE: [X60] 1.5.1 - 20111122 [please check]
It will be hosted here in a few seconds Smile

Edit: done
Visit this user's website Find all posts by this user
Quote this message in a reply
2012-01-25, 13:18 GMT
Post: #8
RE: 1.5.1 - 20111122 [please check]
Unfortunatelly no DRM ;(
Find all posts by this user
Quote this message in a reply
2012-01-25, 23:15 GMT
Post: #9
RE: 1.5.1 - 20111122 [please check]
(2012-01-25 13:18 GMT)theben Wrote:  Unfortunatelly no DRM ;(

I have no idea what you mean by that. Could you elaborate ?
Visit this user's website Find all posts by this user
Quote this message in a reply
2012-03-26, 07:26 GMT
Post: #10
RE: 1.5.1 - 20111122 [please check]
I just updated my X60 (the white version with the wheel button design) to 1.5.1. The upgrade process went flawless. However, the device shuts down immediately after starting up and showing the root menu. Please help.
Find all posts by this user
Quote this message in a reply
Post Reply